freeMXF.org
https://freemxf.org:80/forum/

Complier error in OS X
https://freemxf.org:80/forum/viewtopic.php?f=2&t=180
Page 1 of 1

Author:  Archives [ Thu May 07, 2009 1:04 pm ]
Post subject:  Complier error in OS X

I keep recieving an error with the libmxf.a file when I go to install. I get:

Making install in mxflib
test -z "/usr/local/lib" || /Users/PANBAV/Desktop/freemxf/mxflib-1.0.0/install-sh -d "/usr/local/lib"
/usr/bin/install -c -m 644 'libmxf.a' '/usr/local/lib/libmxf.a'
install: /usr/local/lib/libmxf.a: Permission denied
make[2]: *** [install-libLIBRARIES] Error 71
make[1]: *** [install-am] Error 2
make: *** [install-recursive] Error 1

I'm not very knowledgeble with programming and command line, therefore I am stuck.

I have tried using the sudo command but that yields nothing. I've searched the fourms with no dinifinitive answers.
I've tried this thread: Using MXFlib with Xcode
ut my main problem with that path is that when I open the file I get nothing but garbage(primarily Yen signs).

Any suggestions, hints, etc are appreaciated

PS: Mac Pro, intel Octo-core with 10.5.6, gcc 4.0.1, and Xcode 3

Author:  Matt Beard [ Fri May 08, 2009 7:26 am ]
Post subject: 

I looks like you don't have write permission to /usr/local/lib - on my current machine only root has access to that directory so I would need to be root to do make install.

If you wish to do that you could:

$ sudo su -
# make install
....
# exit

Author:  Archives [ Fri May 08, 2009 5:48 pm ]
Post subject: 

Yeah, that worked. Although my actual problem was that the admin password was nothing, so I had to create an actual password for the sudo command to work properly.

Thanks for the help.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/